當前位置:文檔之家 > 【股票指標公式下載】-【通達信】畫線主圖二(差值、短線、中線、下跌、上軌)

【股票指標公式下載】-【通達信】畫線主圖二(差值、短線、中線、下跌、上軌)

【股票指標公式下載】-【通達信】畫線主圖二(差值、短線、中線、下跌、上軌)

【通達信】畫線主圖二(差值、短線、中線、下跌、上軌)-指標公式源碼

{ TDX N:1,100,8 K:0,1,0 }

TYP := (HIGH + LOW + CLOSE)/3;

CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,6));

差值1:=ABS(REF(CCI1,1)-CCI1),LINETHICK0;

CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));

差值2:=ABS(REF(CCI2,1)-CCI2),LINETHICK0;

CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));

差值3:=ABS(REF(CCI3,1)-CCI3),LINETHICK0;

CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));

差值4:=ABS(REF(CCI4,1)-CCI4),LINETHICK0;

CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));

差值5:=ABS(REF(CCI5,1)-CCI5),LINETHICK0;

CCI:=CCI1+CCI2+CCI3+CCI4+CCI5;

AAAB:=(3*C+H+L+O)/6;

VVAR1:=(8*AAAB+7*REF(AAAB,1)+6*REF(AAAB,2)+5*REF(AAAB,3)+4*REF(AAAB,4 )+3*REF(AAAB,5)+2*REF(AAAB,6)+REF(AAAB,8))/36;

VVAR6:=(LLV(VVAR1,2)+LLV(VVAR1,4)+LLV(VVAR1,6))/3;

短線:IF(K=0, VVAR1, DRAWNULL),COLORWHITE;

中線:IF(K=0,VVAR6, DRAWNULL),COLORYELLOW;

下跌:IF(K=0 AND VVAR1=VVAR6,VVAR6, DRAWNULL),COLORGREEN;

中:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/
4;

中:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;

上軌:=IF(K=1,中+3*STD(中,10),DRAWNULL),COLOR000088,LINETHICK5;

IF(K=1,2*MA(上軌,12)-MA(C,21),DRAWNULL),COLOR666666;

XXX1:=(C+L+H)/3;

XXX2:=EMA(XXX1,6),LINETHICK0;

XXX3:=EMA(XXX2,5),LINETHICK0;

牛背:=MA(C,21);

不錯:=牛背+2*STD(C,21);

熊樣:=牛背-2*STD(C,21);

熊樣1:=IF(K=1,牛背-2*STD(C,21),DRAWNULL);

牛背2:=IF(K=1 AND C>牛背,牛背,DRAWNULL),LINETHICK3;

DRAWBAND(牛背2,RGB(58,58,58),熊樣1,RGB(0,0,0));

中国体彩排列3走势